2019/07/19

Routing using Dynamips and Windows Server 2008 R2

This time, let's introduce how to RIP routing using Windows Server.

you just prepare Windows Server 2008 R2, Vmware and Dynamips.




★ Configuration information.

1. Internet is connected by Microsoft Loopback Adapter.(NAT works automatically)

2. Switch1 works as L3, using RIPv2. and deny RIP protocol information to the Internet connection side.

3. Switch1 and Switch2 are connected using Etherchannel mode ON.

4. Switch1 is  VTP Server. Switch2 is VTP Client. VLAN10 and VLAN20 is setup both side.

5. VLAN10 at Switch1. VLAN20 at between Server and Router, also both side of Switch2.

6. Server works RIPv2 routing protocol.(usingVMware)

7. Router1 works RIPv2 routing protocol.

8. Server and Router1 should  be able to ping to Internet.

9. IP address instruction.

Internet : 1.1.10.1
Switch1  Internet side : 1.1.10.2
Switch1 Loopback : 7.7.7.7
Switch1 VLAN10 : 172.16.1.7
Server Internet side : 172.16.1.10
Server Router1 side : 172.16.2.10
Router1 : 172.16.2.11
Router1 Loopback : 1.1.1.1



★ Configuration at Dynamips

< Router1 >

hostname R1
!
no ip domain lookup
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 172.16.2.11 255.255.255.0
!
router rip
 version 2
 network 1.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.2.10
!
no cdp run
!
line con 0
 exec-timeout 0 0
 logging synchronous

-----------------------------------------------


< Switch 2 >

hostname SW2
!
no ip routing
!
no ip domain lookup
!
interface Port-channel1
 switchport mode trunk
!
interface FastEthernet1/0
 switchport access vlan 10
!
interface FastEthernet1/1
 switchport access vlan 20
!
interface FastEthernet1/13
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/14
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/15
 switchport access vlan 20
!
no cdp run
!
line con 0
 exec-timeout 0 0
 logging synchronous

-----------------------------------------------


< Switch 1 >

hostname SW1
!
no ip domain lookup
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.0
!
interface Port-channel1
 switchport mode trunk
!
interface FastEthernet1/0
 no switchport
 ip address 1.1.10.2 255.255.255.0
 no cdp enable
!
interface FastEthernet1/13
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/14
 switchport mode trunk
 channel-group 1 mode on
!
interface Vlan10
 ip address 172.16.1.7 255.255.255.0
!
router rip
 version 2
 passive-interface default
 no passive-interface FastEthernet1/13
 no passive-interface FastEthernet1/14
 no passive-interface Vlan10
 network 1.0.0.0
 network 7.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 1.1.10.1
!
no cdp run
!
line con 0
 exec-timeout 0 0
 logging synchronous

-----------------------------------------------



★ Routing table will be like this.





★ Configuration at Windows Server 2008 R2



1. Input information to Input NIC interface.(IP address, Subnet, Gateway, DNS)

    Input information to Output NIC interface.(IP address, Subnet)




2. Add routing role. 'Server Manager - Add roles and features'




3. Select 'Network Policy and Access Services'.

    next, select 'Routing and Remote Access Service' and install.




4. After installation. execute "Administrative Tools - Routing and Remote Access'




5. At IPv4 folder, right click and select 'New Routing Protocol'




6. At new RIP protocol and right click. and select 'New Interface'

then, select interface that needed




7. Default value is RIPv2. click OK button.

    other interface's setup is same way.




8. After setup, you can see RIP information like this.





★ After configuration, ping works!




p.s. Windows Server 2008 R2 support only Static and RIP protocol, not support OSPF protocol.


No comments:

Post a Comment