This time, let's try HSRP and NAT test.
especially, this configuration is for loadbalancing, let's make Multiple HSRP.
★ Instructions
1. Make Switches L2 mode.
2. Switch1-1 and Siwtch1-2 are same device.
3. Set NAT at Router1
4. Set HSRP at Router 2,3. Router2 is active router at HSRP1. Router3 is active router at HSRP2.
5. 2 virtual router are running as PC1 and PC2
6. Vlan100 is assigned both interface at Switch1. Vlan200 is assigned between Router 1,2,3.
Vlan30 is assigned Router 2,3,4,5.
★ Configure is like this.
< Switch 1 >
hostname SW1
!
no ip routing
!
no ip domain lookup
!
interface FastEthernet1/0
switchport access vlan 100
!
interface FastEthernet1/1
switchport access vlan 100
!
interface FastEthernet1/2
switchport access vlan 30
!
interface FastEthernet1/3
switchport access vlan 30
!
interface FastEthernet1/4
switchport access vlan 30
!
interface FastEthernet1/5
switchport access vlan 30
!
no cdp run
!
line con 0
exec-timeout 0 0
logging synchronous
-----------------------------------------------
< Router 1 >
hostname R1
!
no ip domain lookup
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 1.1.10.2 255.255.255.0
ip nat outside
!
interface FastEthernet0/1
ip address 1.1.200.1 255.255.255.0
ip nat inside
!
router eigrp 1
redistribute static
network 1.1.1.1 0.0.0.0
network 1.1.10.2 0.0.0.0
network 1.1.200.1 0.0.0.0
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 1.1.10.1
!
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit any
no cdp run
!
line con 0
exec-timeout 0 0
logging synchronous
-----------------------------------------------
< Router 2 >
hostname R2
!
no ip domain lookup
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 1.1.30.2 255.255.255.0
standby 1 ip 1.1.30.11
standby 1 priority 105
standby 1 preempt
standby 1 track FastEthernet0/1
standby 2 ip 1.1.30.22
standby 2 preempt
!
interface FastEthernet0/1
ip address 1.1.200.2 255.255.255.0
!
router eigrp 1
network 1.1.30.2 0.0.0.0
network 1.1.200.2 0.0.0.0
network 2.2.2.2 0.0.0.0
no auto-summary
!
no cdp run
!
line con 0
exec-timeout 0 0
logging synchronous
-----------------------------------------------
< Router 3 >
hostname R3
!
no ip domain lookup
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 1.1.30.3 255.255.255.0
standby 1 ip 1.1.30.11
standby 1 preempt
standby 2 ip 1.1.30.22
standby 2 priority 105
standby 2 preempt
standby 2 track FastEthernet0/1
!
interface FastEthernet0/1
ip address 1.1.200.3 255.255.255.0
!
router eigrp 1
network 1.1.30.3 0.0.0.0
network 1.1.200.3 0.0.0.0
network 3.3.3.3 0.0.0.0
no auto-summary
!
no cdp run
!
line con 0
exec-timeout 0 0
logging synchronous
-----------------------------------------------
< Switch 2 >
hostname SW2
!
no ip routing
!
no ip domain lookup
!
interface FastEthernet1/1
switchport access vlan 200
!
interface FastEthernet1/2
switchport access vlan 200
!
interface FastEthernet1/3
switchport access vlan 200
!
no cdp run
!
line con 0
exec-timeout 0 0
logging synchronous
-----------------------------------------------
< PC 1 >
hostname R4
!
no ip routing
!
no ip domain lookup
!
interface FastEthernet0/0
ip address 1.1.30.4 255.255.255.0
!
ip default-gateway 1.1.30.11
!
no cdp run
!
line con 0
exec-timeout 0 0
logging synchronous
-----------------------------------------------
< PC 2 >
hostname R5
!
no ip routing
!
no ip domain lookup
!
interface FastEthernet0/0
ip address 1.1.30.5 255.255.255.0
!
ip default-gateway 1.1.30.22
!
no cdp run
!
line con 0
exec-timeout 0 0
logging synchronous
-----------------------------------------------
★ Outcomes
1. Using traceroute command, check the route.
route is correctly good.
2. You can check NAT translation using 'show ip nat translations' command.
3. also you can check two HSRP status using 'show standby brief' command.
No comments:
Post a Comment